Com instal·lar els paquets estàndard de PHP 5.x.x a CentOS 5.x

Actualitzat 24/6/2011: si necessites fer servir la versió 5.3 de PHP consulta el següent link: http://chrisjean.com/2011/06/24/upgrade-php-5-1-or-5-2-to-5-3-on-centos/

 

Com ja ha quedat palés, jo utilitzo sovint la distribució CentOS. El problema d’aquesta distribució és que va una mica endarrerida respecte a les versions actuals de la majoria de paquets de Software. Això és degut a que no és més que una versió igual a la que RedHat publica i distribueix amb els paquets de SW més estables. A vegades ens trobem que necessitem una versió més alta de PHP o de MySQL per un tema de compatibilitats amb el SW que estem instal·lant com per exemple podria ser el WordPress o Drupal que exigeixen una versió concreta mínima de PHP per a funcionar corectament. Doncs aleshores la única opció que ens queda és descarregar aquells paquets que ens fan falta des d’un repositori de desenvolupament. Buscant per google he trobat un manual que explica com fer update de PHP a la versió del repositori de desenvolupament per a CentOS ja que la que actualitza el repositori habitual és molt antiga tant per a Drupal com per a Prestashop, …

http://wiki.centos.org/HowTos/PHP_5.1_To_5.2

 

 

Deixa un comentari o pregunta